Outbound Email Delivery Issue
Resolved
Dec 26 at 05:45pm EST
Email delivery has remained stable with no observed delays or delivery issues over the past three days. All systems are operating normally.
We will continue routine monitoring, but no further impact is expected at this time.
Affected services
Updated
Dec 25 at 05:26pm EST
We have not observed any email delivery delays today. This improvement may be influenced by reduced holiday traffic.
We are continuing to monitor email delivery and system behavior closely. We will post another update if conditions change or once we confirm sustained stability.
Affected services
Updated
Dec 24 at 11:26am EST
We have not observed any email delivery delays today. This improvement may be influenced by reduced holiday traffic.
We are continuing to monitor email delivery and system behavior closely. We will post another update if conditions change or once we confirm sustained stability.
Affected services
Updated
Dec 23 at 10:33am EST
We have implemented a priority email queue to ensure delivery of critical messages. Emails related to ACH processing, data import errors, and password resets are now sent with priority and are not affected by current delays.
Other non-critical emails may still experience delivery delays as we continue to stabilize email throughput. We expect all remaining delays to be fully resolved within the next 2 to 3 days.
We will continue to monitor delivery and post additional updates as needed.
Affected services
Updated
Dec 22 at 12:15pm EST
We have addressed most of the spam report issues, but some delays still remain with our email client.
Affected services
Created
Dec 19 at 11:54am EST
Incident details What happened We recently made a configuration change to our email delivery service. Following this change, some outbound emails are being rejected by certain recipient email providers. Impact Some system-generated emails are not being delivered to a subset of recipients. These messages are rejected by recipient mail servers and will not be received. Scope • Outbound emails only • Inbound email is not affected • Impact varies by recipient email provider Current status Email sending is operational, but delivery failures are occurring for some recipients. Actions taken • Identified the source of the delivery issue • Adjusted sending patterns • Actively monitoring email delivery health Next steps • Continue stabilizing email delivery • Monitor rejection rates • Provide updates as delivery normalizes
Affected services